Walkthrough: Objects

From TS3wiki

This page covers a TSR Workshop walkthrough for objects. It requires you to have read the Create New Project Walkthrough.

Contents

3D Preview

3D Preview

Learn more about the 3D Preview and how to use it here.

Project Tab

Project Tab

You can change the following if you forgot to do this at the cloning stage:

  • Name: The catalog name of your item ingame.
  • Description: The catalog description ingame.

You can also set:

  • Price: How much your item costs ingame.
  • Launcher thumbnail: Load in here a 64x64 PNG image which will appear in the launcher.
  • Category flags: Choose here the function/room/build categories your item should appear in.


Textures Tab

Texture Tab

From the dropdown list you can select a variation to show it's texture settings.

  • Click File:AddVariation.jpg to add a new variation (makes a copy of the selected variation).
  • With File:DeleteVariation.jpg you delete the currently selected variation.
  • Export the Composed Texture of the selected variation with this button File:ExportComplateButton.jpg.


Textures

Textures

Here you have the main textures for a variation:

Double click the thumbnail to open the Image Editor to either Export/Import or Browse for the DDS texture.

Patterns

Patterns

Patterns listed here use the RGBA Stencil Mask found under Textures as a mask. The masks are applied the following ways:

  • Red Channel → Pattern A
  • Green Channel → Pattern B
  • Blue Channel → Pattern C

See next how to correctly use a pattern for your creation. Linked is currently unknown but feel free to research it.

  • Pattern A/B/C: Double click the thumbnail to open the Pattern Editor. Choose Browse to open the Pattern Browser where you can look for an existing pattern. Or choose New to make a new pattern for this project with the Pattern Tool. Click on Done when you made the changes.
  • Enabled: If you want to show this channel/pattern you need to set this to True. If you don't want to use this channel/pattern on your creation, set it to False.
  • Tiling: Set here how many times you want the pattern have tiled across the texture in X and Y direction.


Stencils

Stencils

Learn more about Stencils here. You can define up to 4 stencils in A, B, C and D slots.

  • Texture: Load in here your Stencil Texture in DDS format by double clicking the thumbnail.
  • Enabled: If you want to have this Stencil shown on this variation, set it to True. If you don't want to use, set it to False.

Tiling and Rotation are two not very useful entries. You can ignore them.

Browse

If you imported a texture resource already but need it for example for another variation as well, do not import it again! Use Browse instead to select the existing texture resource.

Mesh Tab

Mesh Tab

Choose a mesh to change in the drop down list. With Export File:ExportButton.jpg you can save the mesh in WSO or S3ASC format for editing in a 3D program (only Milkshape 3D currently). Import File:ImportButton.jpg the WSO or S3ASC after you made the changes. With the LOD buttons File:LODbuttons.jpg in the 3D Preview you can toggle between the different meshes:

  • High level of detail
  • Low level of detail

Each mesh in the drop down list has the following group(s) entries:

  • Mesh: Lists the vertex and face count. Click it to see what mesh it is.
  • Visible: Default is True. If you don't want to have it visible ingame for any reason, set it to False.
  • Material: Click File:OpenEditorButton.jpg to open the Material Editor to make the changes.


Material Editor – Final Texture Sizes

After the game engine composes all the textures, it writes two textures. The Specular and the Diffuse texture. In the Material Editor under Mask width and Mask height you can set those texture sizes. It's recommended to set the size of your Multiplier for the Diffuse and Specular texture.

Slots Tab

Slots Tab

Change here the interaction positions for sims and effects. Not all are available on every object.

  • Footprints: Adjust here the footprints of your object item (the area which is occupied by the object or the area which needs to be free for the interaction with a sim). To do this click File:OpenEditorButton.jpg to open the Footprint Editor.
  • Slots: ?
  • Route Entries: The positions your sim walks to to start the animation for the specific object.
  • Slot Entries: The container which holds the sim?
  • Effect Entries: For example the position of the fire effect.
  • Kinematic Entries: Positions for sim skeleton bones during the animation. For example treadles of a bicycle have them.


Misc Tab

Misc Tab

This tab is used for windows/doors/arches only. It shows the wallmasks and their positions.

  • Show wall: True shows a preview for the wallmasks, False hides it. This way you can control if the wallmasks fit your item.
  • Wall color: Choose the color for the wall in the 3D Preview.
  • Wallmasks: Change the textures to correct the cutout for the wall by double clicking them to open the Image Editor. You can ignore the Float values. They are there for the position of the wallmasks.


Save & Export

After you're done, save the TSR Workshop Project if you didn't yet. This allows you to make changes easily after testing ingame:

  • File → Save As/Save

Export the TSR Workshop Project with:

  • File → Export → To Sims3Pack

This creates a fully functional Sims3Pack which can be installed with double click or Merlin into the game.

Additional Links

Personal tools
TSR Workshop
Powered by MediaWiki