Walkthrough: Makeup/Facial overlay

From TS3wiki

This page covers a TSR Workshop walkthrough for makeup/facial overlay. It requires you to have read the Create New Project Walkthrough.

Contents

3D Preview

3D Preview

Learn more about the 3D Preview and how to use it here.

Project Tab

Project Tab

This guide covers the Basic Data, Categories and Extras. The advanced entries, such as Type and Clothing Type you'll rarely use.

Basic Data

Basic Data

You can change the following if you forgot to do this at the cloning stage:

  • Title
  • Description

You can also choose:

  • Age
  • Gender

for which your item is available to.

Description

Your description must NOT have more than 255 characters or the item can't be installed into the game.

Categories

Categories

Choose here in what categories your item should appear ingame. You can have ticked more than one.

Extras

Extras
  • Filename is the Unique Identifier. You can change it here if you forgot to do it during the cloning process. Ignore Filename2.
  • You can load a 64x64 PNG image into Launcher Thumbnail to have a custom launcher thumbnail.


Texture Tab

Texture Tab
  • From the dropdown list you can choose a variation of your makeup/facial overlay item.
  • With File:DuplicateVariation.jpg you can duplicate the current variation and with File:DeleteVariation.jpg you delete the currently selected variation.
  • You can export the Complate of a variation with this button File:ExportComplateButton.jpg (not shown on screenshot).
  • For advanced options in the Texture Tab, tick Advanced.


Textures

Textures

Here you have the textures for a makeup/facial overlay variation. Face Overlay, Face Specular and Mask. Those bold are the ones you should focus on. Double click the thumbnail to open up the Image Editor to either Export/Import or Browse for the DDS texture.

Tint Colors

Tint Colors

The colors listed here use the RGBA Stencil Mask found under Textures as a mask. The masks are applied the following ways:

  • Red Channel → Tint Color A
  • Green Channel → Tint Color B
  • Blue Channel → Tint Color C
  • Alpha Channel → Tint Color D

If you want to use a Tint Color set Tint Color A/B/C/D Enabled to True. If you don't want to use that color in your creation, set it to False.

Save & Export

After you're done, save the TSR Workshop Project if you didn't yet. This allows you to make changes easily after testing ingame:

  • File → Save As/Save

Export the TSR Workshop Project with:

  • File → Export → To Sims3Pack

This creates a fully functional Sims3Pack which can be installed with double click or Merlin into the game.

Additional Links

Personal tools
TSR Workshop
Powered by MediaWiki