Walkthrough: Hair

From TS3wiki

This page covers a TSR Workshop walkthrough for hair. It requires you to have read the Create New Project Walkthrough.

Attention!

TSR Workshop doesn't yet support hair fully. The following walkthrough could include stuff which is outdated or labelled wrong. If you are completely new to TSR Workshop, hair is not the perfect item to learn from.

Contents

3D Preview

3D Preview

Learn more about the 3D Preview and how to use it here.

Project Tab

Project Tab

This guide covers the Basic Data, Categories and Extras. The advanced entries, such as Type and Clothing Type you'll rarely use.

Basic Data

Basic Data

You can change the following if you forgot to do this at the cloning stage:

  • Title
  • Description

You can also choose:

  • Age
  • Gender

for which your item is available to.

Description

Your description must NOT have more than 255 characters or the item can't be installed into the game.

Categories

Categories

Choose here in what categories your item should appear ingame. You can have ticked more than one.

Extras

Extras
  • Filename is the Unique Identifier. You can change it here if you forgot to do it during the cloning process. Ignore Filename2.
  • You can load a 64x64 PNG image into Launcher Thumbnail to have a custom launcher thumbnail.


Texture Tab

Texture Tab

Note: You can't add a variation to a hair item currently.

  • You can export the Complate of the variation with this button File:ExportComplateButton.jpg.
  • For advanced options in the Texture Tab, click File:AdvancedButton.jpg.

Beside the Texture Builder you have several parameters:

  • Param 1: Main hair color.
  • Param 2: Root color.
  • Param 3: Highlights color.
  • Param 4: Tip color.

Double click the thumbnails to open up the Image Editor to either Export/Import or Browse for the DDS textures:

  • Param 5: That's the place to import the Multiplier texture.
  • Param 6: Again the Multiplier texture. Use Browse to select the existing texture you imported at Param 5.
  • Param 7: Unknown
  • Param 8: Unknown


Browse

If you imported a texture resource already but need it for example for another variation as well, do not import it again! Use Browse instead to select the existing texture resource.

Mesh Tab

Mesh Tab

The Mesh Tab for hair has has four LOD entries. With the LOD buttons File:LODbuttons.jpg in the 3D Preview you can toggle between the different meshes:

  • Level 0 (Very high level of detail used in CAS)
  • High level of detail
  • Medium level of detail
  • Low level of detail


Each of them has the following entries:

  • Mesh: Here you can export the Mesh to WSO Format to edit it and import it back. Learn more about the Workshop Object Format here.
  • DDS(1): Unknown
  • DDS(2): This contains a reference to the Multiplier Texture. Use Browse to select the texture you have imported already in the Texture Tab.
  • DDS(3): This is the place to import the Normal Map for your mesh. After you imported it, use the Browse button for the other levels of detail.
  • DDS(4): This entry has a reference to the Specular Texture. After you imported it, use the Browse button for the other levels of detail.

BONE is currently disabled.

Save & Export

After you're done, save the TSR Workshop Project if you didn't yet. This allows you to make changes easily after testing ingame:

  • File → Save As/Save

Export the TSR Workshop Project with:

  • File → Export → To Sims3Pack

This creates a fully functional Sims3Pack which can be installed with double click or Merlin into the game.

Personal tools
TSR Workshop
Powered by MediaWiki