Walkthrough: Clothing

From TS3wiki

This page covers a TSR Workshop walkthrough for clothing. It requires you to have read the Create New Project Walkthrough.

Contents

3D Preview

3D Preview

Learn more about the 3D Preview and how to use it here.

Project Tab

Project Tab

This guide covers the Basic Data, Categories and Extras. The advanced entries, such as Type and Clothing Type you'll rarely use.

Basic Data

Basic Data

You can change the following if you forgot to do this at the cloning stage:

  • Title
  • Description

You can also choose:

  • Age
  • Gender

for which your item is available to.

Description

Your description must NOT have more than 255 characters or the item can't be installed into the game.

Categories

Categories

Choose here in what categories your item should appear ingame. You can have ticked more than one.

Extras

Extras
  • Filename is the Unique Identifier. You can change it here if you forgot to do it during the cloning process. Ignore Filename2.
  • You can load a 64x64 PNG image into Launcher Thumbnail to have a custom launcher thumbnail.


Texture Tab

Texture Tab
  • From the dropdown list you can choose a variation of your clothing item.
  • With File:DuplicateVariation.jpg you can duplicate the current variation and with File:DeleteVariation.jpg you delete the currently selected variation.
  • Export the Complate of a variation with this button File:ExportComplateButton.jpg (not shown on screenshot).
  • For advanced options in the Texture Tab, click File:AdvancedButton.jpg.


PartHighlighting, Settings and Logo aren't covered here since those you probably never need to change.

Textures

Textures

Here you have the main textures for a variation. Overlay, Mask, Multiplier, Skin Specular, Skin Ambient, Clothing Specular, Clothing Ambient and Part Mask. Those bold are the ones you should focus on. Double click the thumbnail to open up the Image Editor to either Export/Import or Browse for the DDS texture.

Patterns

Patterns

Patterns listed here use the RGBA Stencil Mask found under Textures as a mask. The masks are applied the following ways:

  • Red Channel → Pattern A
  • Green Channel → Pattern B
  • Blue Channel → Pattern C


See next how to correctly use a pattern for your creation. Linked is currently unknown but feel free to research it.

  • Pattern A/B/C: Double click the thumbnail to open the Pattern Editor. Choose Browse to open the Pattern Browser where you can look for an existing pattern. Or choose New to make a new pattern for this project with the Pattern Tool. Click on Done when you have chosen the right pattern.
  • Enabled: If you want to show this channel/pattern you need to set this to True. If you don't want to use this channel/pattern on your creation, set it to False.
  • Tiling: Set here how many times you want the pattern have tiled across the texture in X and Y direction. On clothing items this is 4x4 by default. Tilings such as 2x4 or 6x6 are also possible.
  • Colors: Choose here the prefered colors for your pattern.


HSV?

Some EA patterns make use of HSV (hue, saturation, value). Those currently can't be edited properly in TSR Workshop yet.

Stencils

Stencils

Learn more about Stencils here. You can define up to 6 stencils in A, B, C, D, E and F slots.

  • Texture: Load in here your Stencil Texture in DDS format by double clicking the thumbnail.
  • Enabled: If you want to have this Stencil shown, set it to True. If you don't want to use it on your creation, set it to False.

Tiling and Rotation are two not very useful entries. You can ignore them.

Browse

If you imported a texture resource already but need it for example for another variation as well, do not import it again! Use Browse instead to select the existing texture resource.

Mesh Tab

Mesh Tab

The Mesh Tab for clothing has has three LOD entries. With the LOD buttons File:LODbuttons.jpg in the 3D Preview you can toggle between the different meshes:

  • High level of detail
  • Medium level of detail
  • Low level of detail


Each of them has the following entries:

  • Mesh: Here you can export the Mesh to WSO Format to edit it and import it back. Learn more about the Workshop Object Format here.
  • DDS(1): This is the place to import the Normal Map for your mesh. After you imported it, use the Browse button for the other levels of detail.
  • DDS(2): This contains a reference to the Multiplier Texture. Use Browse to select the texture you have imported already in the Texture Tab.
  • DDS(3): This entry has a reference to the Specular Texture. Use the Browse button here too to look for the already imported texture.

BONE is currently disabled.

Save & Export

After you're done, save the TSR Workshop Project if you didn't yet. This allows you to make changes easily after testing ingame:

  • File → Save As/Save

Export the TSR Workshop Project with:

  • File → Export → To Sims3Pack

This creates a fully functional Sims3Pack which can be installed with double click or Merlin into the game.

Personal tools
TSR Workshop
Powered by MediaWiki