RGBA Stencil Mask

From TS3wiki

This page covers the RGBA Stencil Mask and how it works. It shows workarounds in different 2D applications too.

Contents

Overview

Create-A-Style (Red, Green, Blue, Alpha)

The RGBA Stencil Mask in The Sims 3 has up to four channels (Red, Green, Blue, Alpha) to hold greyscale images. These are used to give transparency information to colors or patterns. White is 100% opaque, black is invisible and all greys are anything inbetween.

Pattern Mask

Can be saved and imported to the Pattern Tool as:

  • DDS → 8.8.8.8 ARGB 32 bpp | unsigned
  • PNG (no alpha channel support)
  • BMP (no alpha channel support)
Basic Pattern RGBA Mask + Composited Colors
Advanced Pattern RGBA Mask + Composited Colors

Mesh Mask

Can be saved and imported to the TSR Workshop as:

  • DDS → DXT1 RGB 4 bpp | no alpha (if alpha channel isn't needed)
  • DDS → DXT5 ARGB 8 bpp | interpolated alpha
Mesh RGBA Mask + Composited Patterns


Working with Channels

Different image editing programs offer different workarounds to edit channels.

DDS Plug-ins

In order to open/save the RGBA Stencil Mask in DDS format you probably need a plugin for your 2D application. See this page if a plug-in is available for your program.

Photoshop

Photoshop Channels Window with Green Channel selected for editing.
  • Windows → Channels

You need to select a channel to edit it. For example paste in a previously finished mask or paint with greyscale colors. If you need an alpha for your mask and there's none, click on the little page icon at the bottom of the window.

Paint Shop Pro

Split Channels in Paint Shop Pro
  • Image → Split Channel → Split to RGB

This will provide you the Red, Green and Blue Channel in separate windows where you can edit them as you like. After making the changes, go to:

  • Image → Combine Channel → Combine from RGB...

Define your channel sources. This puts the channels again into one image.

Adding Alpha Channel

After combining you can add a separate prepared Alpha Channel this way to the RGB image:

  • Layers → New Mask Layer → From Image...

Check Source luminance and uncheck Invert mask data and click OK. After this, do the following:

  • Layers → Load/Save Mask → Save Mask To Alpha Channel...


GIMP

GIMP Channels Window with Alpha Channel selected for editing.
  • Window → Dockable Dialogs → Channels

The window might be already open and can be found under this icon .Select a channel to edit it. For example paste in a previously finished mask or paint with greyscale colors. If you need an alpha for your mask and there's none, click on the little page icon at the bottom of the window to add one.

Personal tools
TSR Workshop
Powered by MediaWiki