Import/Export

From TS3wiki

This page covers the Import and Export functions of TSR Workshop for projects, sims3packs, packages, textures, 3D geometry, patterns and complates.

Contents

Workshop Project (WRK)

  • File → Open
  • File → Save/Saves as

Workshop Project (WRK) is designed to save work-in-progress projects to the harddrive. It's recommended to save your project in WRK so you can always go back and make needed changes.

Sims3Pack

Sims3Pack installs correctly into the game

Whenever you want to create a final creation for upload, export with this format. It's simple to install, Sims3Pack installed items upload with lots, it's compressed and can be easily handled with the game launcher or TSR Launcher by double clicking.

  • File → Export → To Sims3Pack

Package

Package doesn't install correctly into the game

The package format is not designed to be used for downloadable custom content! Packages aren't recognized by the game as custom content and won't therefore be packed with lots and sims. Workshop supports this format for the exchange with other modding tools and doesn't compress the resources upon export.

  • Edit → Project contents → Export → To .package
  • Edit → Project contents → Import → From .package

Textures (DDS)

Textures can be imported/exported via the Image Editor. Learn more about DDS here. These files can be edited with:

Workshop Object (WSO)

  • Mesh Tab → (Choose mesh from dropdown list) → Import
  • Mesh Tab → (Choose mesh from dropdown list) → Export

The WSO-format is designed to exchange The Sims 3 meshes between TSR Workshop and your 3D application. Currently plug-ins are available for Milkshape 3D. Plug-ins for other software are planned.

Plug-ins

You find the currently available plug-ins for 3D programs in the following directory:

  • C:\Program Files\The Sims Resource\TSR Workshop\Extras\...

Milkshape 3D

Put the files msTSRWorkshopExport.dll and msTSRWorkshopImport.dll into:

  • C:\Program Files\MilkShape 3D 1.8.5

Milkshape 1.8.5 or higher is required for the plug-ins to work.

Workshop Pattern (WSP)

This format can be used to exchange patterns between different Workshop projects. The import/export functions can be found in the Pattern Editor.

Workshop Texture Preset (WST)

Experimental!

Workshop Texture Preset (WST) is designed to exchange complates between different materials/projects. The import/export functions are located in the PROP Editor which can be accessed by double clicking a complate in the Material Editor.

Personal tools
TSR Workshop
Powered by MediaWiki