3D Programs

From TS3wiki

This page covers the most popular 3D applications and how to use them together with TSR Workshop.

Contents

Milkshape 3D

Milkshape 3D is shareware and costs US$35. You need MilkShape 3D 1.8.5 in order to have the WSO plug-ins work.

WSO Plug-ins

Download and install the latest version of TSR Workshop. The WSO plug-ins allow for direct interaction with TSR Workshop and can be found in:

  • C:\Program Files\The Sims Resource\TSR Workshop\Extras\Milkshape Plugins

The two files msTSRWorkshopExport.dll and msTSRWorkshopImport.dll need to be placed in:

  • C:\Program Files\Milkshape 1.8.5

You need to restart Milkshape 3D in order to have the plug-ins show up.

How to use

  • File → Import/Export → TSRW Object

Wings 3D (Freeware)

Wings 3D is an easy to use freeware 3D application.

Workflow

For exchanging 3D data with Milkshape 3D:

  • File → Import/Export → Wavefront (.obj)…

Blender (Freeware)

Blender is a "high end" completely free 3D application, with many advanced features comparable to those found in professional 3D packages such as 3D Studio Max, Maya, Cinema4D, and others.

Workflow

Blender can be incorporated into Sims 3 creators' workflow quite easily. You can create meshes directly in Blender, or you can import meshes from other 3D programs. As of currently, meshes can not be taken directly from Blender into TSR Workshop.

Import

  • File → Import → Wavefront (.obj)

The following options upon import need to be changed:

OptionValue
Enable Smooth Groups If mesh has parts that need to be smoothed, enabled. If not, disabled
Separate By Group
Clampscale 0.0
Image Search Off

Export

  • File → Export → Wavefront (.obj)

The following options upon export need to be changed:

OptionValue
Export Triangulate
Export Normals
Blender Objects as OBJ If exporting more than one mesh at a time, "groups"

Import into Milkshape 3D

In order to then get the mesh into Milkshape, you simply need to import the .obj:

  • File → Import → Wavefront (.obj)

Please note that the a .wso file should be imported before an .obj file

If you exported more than one group from Blender, they should be listed under the Groups tab. Once the mesh has been imported on top of the .wso, you can then proceed to rename groups and assign joints, etc.

3D Studio Max

3D Studio Max is a high-end 3D modelling application, owned by Autodesk. The price for the latest version (3D Studio Max 2010) ranges from $3,495.00 to $3,999.00.

Older versions are available, and in my opinion there isn't much difference between the earlier versions (Max 9, 2008, 2009). These can be brought at a cheaper price from alternative websites.

The software can run perfectly in both 32-bit and 64-bit Operating Systems. Currently, you can only natively run the software on a Windows based PC, however Autodesk offers full support for 3D Studio Max on Mac if you run it via Parallels Dektop.

Utilities

Service Packs are released by Autodesk generally once per software version to fix various bug that the software has. I would strongly recommend downloading the Service pack that corresponds with your version of Max.

Maya

Maya is a high end, expensive program that can be used to create meshes that can be put into The Sims 3. An user license costs up to around $7-$8,000. Generally not recommended to purchase if you're only interest is creating for TS3, but if you are already familiar with it and own a copy, it can be used.

Workflow

Maya can be incorporated into a Sims 3 creators' work flow quite easily. It supports the standard .obj format, meshes can be imported and exported.

Enabling .obj Export

First off, you need to enable the .obj export script. This can be done via:

  • Window → Settings/Preferences → Plug-In Manager

Scroll down the list until you see objExport.mll. Make sure the boxes for "Loaded" and "Auto-Load" are both checked. This will enable .obj while Maya is running now, and will set it to load this plug-in automatically next time you load Maya.

Configuring .obj Export

The .obj format has a few global capabilities, such as groups, materials, etc. Not all of these are needed, though. Go to:

  • File → Export Selected

and click the Options button at the bottom of the window.

Under File Type Specific Options, you will see a list of several things that .obj can support. All of them will be enabled by default. Turn Point Groups and Materials off, then close the window.

Notes about Exporting

The File menu has two export options:

  • Export All
  • Export Selection…

Generally, I find that using "Export Selection" to export only the selected mesh a good option. If you are trying to export more than one mesh at a time, you will need to either select everything you want to export, or use Export All… to export the entire scene to a .obj file.

Import into Milkshape 3D

.Obj format files exported from Maya will import without issue into Milkshape 3D via:

  • File → Import → Wavefront OBJ…

A .wso format file from Workshop should be imported into Milkshape before importing any .obj files

All groups should remain intact if you check under the Group tab. If your mesh has successfully imported, you can then proceed to go ahead and assign joints, rename subsets, etc.

Cinema 4D

Cinema 4D is a highend 3D software package and costs around US$995 for the core version.

Utilities

Add Normals

This plug-in will allow you to add the normals data to your meshes before export.

Extract the AddNormals folder to C:\Program Files\MAXON\Cinema 4D R[9.1+]\plugins and restart Cinema 4D.

How to use

Select each mesh before export and click Plugins → Add/Update Normal Tag.

Riptide OBJ Ex-/Import

This plug-in is required to correctly write OBJ files which can be imported into Milkshape 3D and then via WSO into TSR Workshop.

Follow the installation instructions on that page.

How to use
Riptide Export Options

After you added the normals click Plugins → Riptide → .Obj Exporter and enter a filename and the destination you want to save your OBJ file to. The afterwards popping up export options should be as follows as shown on the right.

Personal tools
TSR Workshop
Powered by MediaWiki