2D Programs

From TS3wiki

This page shows different 2D applications and their plugins for texture editing in The Sims 3.

Contents

Photoshop

Photoshop is the industry's standard and costs around US$699.

DDS & Normal Map Plug-ins

Click on Download Current Version to download the file and then install it.

If your Photoshop is in English the installer might have chosen the right destination in the Photoshop directory for the plug-ins. If it’s not then you have to translate the folders name to know where to move the plug-ins to.

For dds.8bi:

  • C:\Program Files\Adobe\Adobe Photoshop CSX\plug-ins\file format

For NormalMapFilter.8bf:

  • C:\Program Files\Adobe\Adobe Photoshop CSX\plug-ins\filters

Working with Channels

Photoshop Channels Window with Green Channel selected for editing.
  • Windows → Channels

You need to select a channel to edit it. For example paste in a previously finished mask or paint with greyscale colors. If you need an alpha for your mask and there's none, click on the little page icon at the bottom of the window.

GIMP (Freeware)

GIMP is similar to Photoshop in many aspects and is freeware.

DDS Plug-in

Download the Windows 32-bit binaries and place the extracted dds.exe file in the GIMP plug-in folder, usually located at C:\Program Files\GIMP-2.0\lib\gimp\2.0\plug-ins.

Normal Map Plug-in

Download the Windows 32-bit binaries. To install, extract the normalmap.exe file to your GIMP plugins directory usually located at:

C:\Program Files\GIMP-2.0\lib\gimp\2.0\plug-ins

Then extract the 3 dll files to your GIMP bin directory. This directory is usually located at:

C:\Program Files\GIMP-2.0\bin

Working with Channels

GIMP Channels Window with Alpha Channel selected for editing.
  • Window → Dockable Dialogs → Channels

The window might be already open and can be found under this icon .Select a channel to edit it. For example paste in a previously finished mask or paint with greyscale colors. If you need an alpha for your mask and there's none, click on the little page icon at the bottom of the window to add one.

Paint Shop Pro

This software from Corel costs around US$99. As the name says it focuses on photography and is not suited for game design.

DDS Plug-in

Create a folder called PlugIns under C:\Program Files\Corel\Corel Paint Shop Pro Photo X2\PlugIns. You need to do the same with the older version of PSP. The directory will read a bit different. Copy the DDS Plug-in to the PlugIns folder. If you downloaded the plug-in as an .exe file, it should install to this folder.

If you are using PSP X2, you will need to enable your plug-ins. You do this by going to File -> Preferences -> File locations. Under File types, select Plug-ins. Uncheck Limit load plug-in to those with an .8B? extension only. If the location of your plug-in file isn't listed, click add and browse for it. Under the folder options make sure Enable and Use Sub Folders are checked.

Normal Map Plug-in

As of Paint Shop Pro 9 the NVIDIA Normal Map Plug-ins are no longer supported. Use Photoshop or GIMP instead.

Working with Channels

Split Channels in Paint Shop Pro
  • Image → Split Channel → Split to RGB

This will provide you the Red, Green and Blue Channel in separate windows where you can edit them as you like. After making the changes, go to:

  • Image → Combine Channel → Combine from RGB...

Define your channel sources. This puts the channels again into one image.

Adding Alpha Channel

After combining you can add a separate prepared Alpha Channel this way to the RGB image:

  • Layers → New Mask Layer → From Image...

Check Source luminance and uncheck Invert mask data and click OK. After this, do the following:

  • Layers → Load/Save Mask → Save Mask To Alpha Channel...
Personal tools
TSR Workshop
Powered by MediaWiki